Готовый модуль отправки СМС 1С:Предприятие 8

С помощью API можно отправлять одиночные СМС-сообщения и осуществлять СМС-рассылку из 1С:Предприятие 8.

Шаг 1 - Зарегистрируйтесь в нашем личном кабинете

 На Ваш e-mail поступит пароль, который необходимо будет использовать в API.

Шаг 2 - Скачайте архив с исходным открытым кодом отправки СМС из 1C:Предприятие 8

Архив содержит исходный код файла обработчика "Отправка СМС.ert", текст кода и библиотеку V7PLUS.DLL. Скачать готовый скрипт отправки СМС из 1С:Предприятие 8.

Пример отправки СМС из 1С:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
Функция UTF8(Ст)
     Стр = ст;
     Стрим = Новый COMОбъект( "Adodb.Stream" );
     Стрим.Type = 2;
     Стрим.Mode = 3;
     Стрим.charset="utf-8";
     Стрим.Open();
     Стрим.WriteText(Стр);
     Стрим.Position=0;
     Стрим.charset="windows-1251";
     Рез=Стрим.ReadText(-1);
     Стрим.Close();
     Рез = СтрЗаменить(Рез, " ", "%20");     //С пробелом не отправлял сообщения
     возврат Рез;
КонецФункции
 
Процедура КнопкаВыполнитьНажатие(Кнопка)
     Логин          = "ВашЛогин";
     Пароль         = "ВашПароль";
     НомерТелефона  = "КодаШлемСМС";
     ИмяОтправителя = "test_sms";
 
     Сервер = "api.sms-prosto.ru";
 
     Запрос = "/?method=push_msg"+
         "&email=" + Логин+
             "&password="+Пароль+
             "&text=" +UTF8("Тестовое сообщение")+
             "&phone="+НомерТелефона+
             "&sender_name="+ИмяОтправителя;
 
     имяВыходногоФайла = "E:\1C-Bases\Отчеты и Обработки\Тестовые, в работе\REQUEST.xml";
 
     Соединение = Новый HTTPСоединение(Сервер);
     Соединение.Получить(запрос, имяВыходногоФайла);
 
//Разбираем ответ с сервера
     ЧтениеXML = Новый ЧтениеXML;
     ЧтениеXML.ОткрытьФайл(имяВыходногоФайла);
     Пока ЧтениеXML.Прочитать() Цикл
         ЭлементыФормы.ПолеТекстовогоДокумента1.ДобавитьСтроку(ЧтениеXML.ЛокальноеИмя);
         Если Строка(ЧтениеXML.ТипУзла) = "Начало элемента" Тогда
             ЧтениеXML.Прочитать();
             КодОшибки = ЧтениеXML.Значение;
         КонецЕсли;
 
         Если Строка(ЧтениеXML.ЛокальноеИмя) = "err_code" И Строка(ЧтениеXML.ТипУзла) = "Начало элемента" Тогда
             ЧтениеXML.Прочитать();
             КодОшибки = ЧтениеXML.Значение;
         КонецЕсли;
 
         Если Строка(ЧтениеXML.ЛокальноеИмя) = "id" И Строка(ЧтениеXML.ТипУзла) = "Начало элемента" Тогда
             ЧтениеXML.Прочитать();
             ИД_сообщения = ЧтениеXML.Значение;
         КонецЕсли;
     КонецЦикла;
 
     ЧтениеXML.Закрыть();
 
     КонецПроцедуры

Скачать готовый скрипт отправки СМС из 1С:Предприятие 8

Если у вас возникли какике-то вопросы, тогда оставте заявку и мы обязательно свяжемся с вами!

Нажимая кнопку, Вы даете согласие на обработку персональных данных в соответствии с условиями, указанными по ссылке

Спасибо за Вашу заявку! В ближайшее время мы с Вами свяжемся.

Не нашли, что искали? Оставьте Ваши контакты, и мы свяжемся с Вами в ближайшее время!

Нажимая кнопку, Вы даете согласие на обработку персональных данных в соответствии с условиями, указанными по ссылке

Спасибо за Вашу заявку! В ближайшее время мы с Вами свяжемся.

Выберите Ваш город