Готовый модуль отправки СМС 1С:Предприятие 7

С помощью API можно отправлять одиночные СМС-сообщения и осуществлять СМС-рассылку из 1С:Предприятие 7.

Обработка - файл "Отправка СМС.ert". Обработчик работает на любой конфигурации 1С:Предприятие 7 и требует наличия компоненты v7plus.dll (в архиве с исходниками прилагается), которую нужно поместить в каталог БД. В некоторых случаях может потребоваться прописать данную компоненту, в зависимости от операционной системы.

Шаг 1 - Зарегистрируйтесь в нашем личном кабинете

 На Ваш e-mail поступит пароль, который необходимо будет использовать в API.

Шаг 2 - Скачайте архив с исходным открытым кодом отправки СМС из 1C:Предприятие 7

Архив содержит исходный код файла обработчика "Отправка СМС.ert", текст кода и библиотеку V7PLUS.DLL. Скачать готовый скрипт отправки СМС из 1С:Предприятие 7.

Пример отправки СМС из 1С:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
Функция ПреобразоватьСтрокуВУТФ8(Стр)     //преобразование текста в формат utf-8
    Длина=СтрДлина(Стр);
    Итог="";
    Для Н=1 По Длина Цикл
        Знак=Сред(Стр,Н,1);
        Код=КодСимв(Знак);
        Если Код<128 Тогда
            Итог=Итог+Знак;
        Иначе
            Если (Код>=КодСимв("А"))И(Код<=КодСимв("п")) Тогда
                Итог=Итог+Симв(208)+Симв(144+Код-КодСимв("А"));
            ИначеЕсли (Код>=КодСимв("р"))И(Код<=КодСимв("я")) Тогда
                Итог=Итог+Симв(209)+Симв(128+Код-КодСимв("р"));
            ИначеЕсли (Знак="ё") Тогда
                Итог=Итог+Симв(209)+Симв(145);
            ИначеЕсли (Знак="Ё") Тогда
                Итог=Итог+Симв(208)+Симв(129);
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    Возврат Итог;
КонецФункции
 
Процедура Выполнить()
     
    Отправитель="+79020982348";
    Логин=СокрЛП(ТекстЛогин);
    Пароль=СокрЛП(ТекстПароль);
    Получатель=СокрЛП(Телефон);
    Сообщение=СокрЛП(ТекстСМС);
    Сообщение=ПреобразоватьСтрокуВУТФ8(Сообщение);   
    ТекстЗапроса="http://api.sms-prosto.ru/?method=push_msg&email="+Логин+"&password="+Пароль+"&text="+Сообщение+"&phone=%20"+Получатель+"&sender_name="+Отправитель; 
    Результат="";
    Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "v7plus.dll") <> 1 Тогда
        ТекстОшибки = "Компонента v7plus.dll не найдена!";
        Форма.Параметр=0;
        Сообщить(ТекстОшибки);
        Возврат;
    КонецЕсли; 
     
    Ошибка=0;
    Соединение =  СоздатьОбъект("AddIn.V7HttpReader");
    Попытка
        Соединение.ОтправитьДляОбработки(ТекстЗапроса,каталогиб()+"\temp.txt", 1,Результат, 2);
    Исключение
        Ошибка=1;
        Предупреждение("СМС не отправлено!");
        Форма.Параметр=0;
    КонецПопытки;
     
    Если Ошибка=0 Тогда
        Предупреждение("СМС отправлено!");
        Форма.Параметр=1;
    КонецЕсли; 
    Сообщить("Ответ сервера: "+Результат);
КонецПроцедуры 

Скачать готовый скрипт отправки СМС из 1С:Предприятие 7

Если у вас возникли какике-то вопросы, тогда оставте заявку и мы обязательно свяжемся с вами!

Нажимая кнопку, Вы даете согласие на обработку персональных данных в соответствии с условиями, указанными по ссылке

Спасибо за Вашу заявку! В ближайшее время мы с Вами свяжемся.

Не нашли, что искали? Оставьте Ваши контакты, и мы свяжемся с Вами в ближайшее время!

Нажимая кнопку, Вы даете согласие на обработку персональных данных в соответствии с условиями, указанными по ссылке

Спасибо за Вашу заявку! В ближайшее время мы с Вами свяжемся.

Выберите Ваш город